const regex = /^(\d{2}){1,2}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\d{2}){1,2}$', 'gm')
const str = `00
01
11
99
2020
3000
3021
1
123
43221
215467`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}