import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\d{2}){1,2}$";
final String string = "00\n"
+ "01\n"
+ "11\n"
+ "99\n"
+ "2020\n"
+ "3000\n"
+ "3021\n\n"
+ "1\n"
+ "123\n"
+ "43221\n"
+ "215467";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}