using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""(?<sep>\s*,\s*)\w*=""";
string input = @"artist=""Awesome artist"", album=""I'm, containing, some, commas,"", title=""Awesome album""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}