const regex = /"(?<sep>\s*,\s*)\w*="/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"(?<sep>\\s*,\\s*)\\w*="', 'mg')
const str = `artist="Awesome artist", album="I'm, containing, some, commas,", title="Awesome album"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}