re = /"(?<sep>\s*,\s*)\w*="/m
str = 'artist="Awesome artist", album="I\'m, containing, some, commas,", title="Awesome album"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end