$re = '/"(?<sep>\s*,\s*)\w*="/mU';
$str = 'artist="Awesome artist", album="I\'m, containing, some, commas,", title="Awesome album"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);