package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mU)"(?<sep>\s*,\s*)\w*="`)
var str = `artist="Awesome artist", album="I'm, containing, some, commas,", title="Awesome album"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}