import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\h*\\S.*)(?:\\R\\h*)*\\R(\\h*\\S.*)(?:\\R\\h*)*(?=\\R/{24})";
final String string = "1.58%\n"
+ "0009\n"
+ "1991\n"
+ "/////////////////////////\n"
+ "Phil\n"
+ "ttr0018\n\n"
+ "1991\n\n"
+ "/////////////////////////";
final String subst = "$1 $2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}