const regex = new RegExp('^(\\h*\\S.*)(?:\\R\\h*)*\\R(\\h*\\S.*)(?:\\R\\h*)*(?=\\R/{24})', 'gm')
const str = `1.58%
0009
1991
/////////////////////////
Phil
ttr0018
1991
/////////////////////////`;
const subst = `$1 $2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);