re = /^(\h*\S.*)(?:\R\h*)*\R(\h*\S.*)(?:\R\h*)*(?=\R\/{24})/m
str = '1.58%
0009
1991
/////////////////////////
Phil
ttr0018
1991
/////////////////////////'
subst = '$1 $2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result