use strict;
my $str = '1.58%
0009
1991
/////////////////////////
Phil
ttr0018
1991
/////////////////////////';
my $regex = qr~^(\h*\S.*)(?:\R\h*)*\R(\h*\S.*)(?:\R\h*)*(?=\R/{24})~mp;
my $subst = '$1 $2';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";