# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<a[^>]*>(.*?)<\\/a>/\1/gm;t' <<< "<a href=\"http://www.anydomain.com/2\">anchor text</a>"