$re = '/<a[^>]*>(.*?)<\/a>/m';
$str = '<a href="http://www.anydomain.com/2">anchor text</a>';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;