re = /<a[^>]*>(.*?)<\/a>/m
str = '<a href="http://www.anydomain.com/2">anchor text</a>'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result