const regex = /<a[^>]*>(.*?)<\/a>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<a[^>]*>(.*?)<\\\/a>', 'gm')
const str = `<a href="http://www.anydomain.com/2">anchor text</a>`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);