package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<a[^>]*>(.*?)<\/a>`)
var str = `<a href="http://www.anydomain.com/2">anchor text</a>`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}