use strict;
my $str = '{"name":" won",addr:" seoul 2 ","age": 2}';
my $regex = qr/("\s+|^[\w\s\w])|(\s+")/mp;
my $subst = '"';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";