$re = '/("\s+|^[\w\s\w])|(\s+")/m';
$str = '{"name":"  won",addr:" seoul 2 ","age": 2}';
$subst = "\"";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;