using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(import)(?:.+?)(\s+from\s+|\s+as\s+)*(?:.+?)$";
string input = @"import ""./test""
import ""./test"" as Test
import { Test } from ""./test""
import { Person as Individual } from ""./test""
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}