import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(import)(?:.+?)(\\s+from\\s+|\\s+as\\s+)*(?:.+?)$";
final String string = "import \"./test\"\n"
+ "import \"./test\" as Test\n"
+ "import { Test } from \"./test\"\n"
+ "import { Person as Individual } from \"./test\"\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}