$re = '/^(import)(?:.+?)(\s+from\s+|\s+as\s+)*(?:.+?)$/m';
$str = 'import "./test"
import "./test" as Test
import { Test } from "./test"
import { Person as Individual } from "./test"
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);