re = /^(import)(?:.+?)(\s+from\s+|\s+as\s+)*(?:.+?)$/m
str = 'import "./test"
import "./test" as Test
import { Test } from "./test"
import { Person as Individual } from "./test"
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end