package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(import)(?:.+?)(\s+from\s+|\s+as\s+)*(?:.+?)$`)
var str = `import "./test"
import "./test" as Test
import { Test } from "./test"
import { Person as Individual } from "./test"
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}