#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)example.com\/(?!fr|FR)"
Local $sString = "example.com/fr/products/lighting" & @CRLF & _
"example.com/fr/products/kitchen" & @CRLF & _
"example.com/FR/products" & @CRLF & _
"example.com/de/products/lighting" & @CRLF & _
"example.com/it" & @CRLF & _
"example.com/en/products/outdoor-furniture"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")