re = /example.com\/(?!fr|FR)/m
str = 'example.com/fr/products/lighting
example.com/fr/products/kitchen
example.com/FR/products
example.com/de/products/lighting
example.com/it
example.com/en/products/outdoor-furniture'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end