using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"example.com\/(?!fr|FR)";
string input = @"example.com/fr/products/lighting
example.com/fr/products/kitchen
example.com/FR/products
example.com/de/products/lighting
example.com/it
example.com/en/products/outdoor-furniture";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}