import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "example.com\\/(?!fr|FR)";
final String string = "example.com/fr/products/lighting\n"
+ "example.com/fr/products/kitchen\n"
+ "example.com/FR/products\n"
+ "example.com/de/products/lighting\n"
+ "example.com/it\n"
+ "example.com/en/products/outdoor-furniture";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}