#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)const\s+([a-zA-Z0-9_$]+)\s*=\s*computed\(\s*\(\)\s*=>\s*{([^{}]*(?:{[^{}]*}[^{}]*)*)}\s*\)"
Local $sString = "const foo = computed(() => {" & @CRLF & _
" // })" & @CRLF & _
" let total = 0" & @CRLF & _
" for (let i = 0; i < items.value.length; i++) {" & @CRLF & _
" total += items.value[i].price" & @CRLF & _
" }" & @CRLF & _
" for (let i = 0; i < items.value.length; i++) {" & @CRLF & _
" total += items.value[i].price" & @CRLF & _
" }" & @CRLF & _
" for (let i = 0; i < items.value.length; i++) {" & @CRLF & _
" total += items.value[i].price" & @CRLF & _
" }" & @CRLF & _
" return total" & @CRLF & _
"})"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")