// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?s)const\s+([a-zA-Z0-9_$]+)\s*=\s*computed\(\s*\(\)\s*=>\s*{([^{}]*(?:{[^{}]*}[^{}]*)*)}\s*\)").unwrap();
let string = "const foo = computed(() => {
// })
let total = 0
for (let i = 0; i < items.value.length; i++) {
total += items.value[i].price
}
for (let i = 0; i < items.value.length; i++) {
total += items.value[i].price
}
for (let i = 0; i < items.value.length; i++) {
total += items.value[i].price
}
return total
})";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}