const regex = /const\s+([a-zA-Z0-9_$]+)\s*=\s*computed\(\s*\(\)\s*=>\s*{([^{}]*(?:{[^{}]*}[^{}]*)*)}\s*\)/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('const\\s+([a-zA-Z0-9_$]+)\\s*=\\s*computed\\(\\s*\\(\\)\\s*=>\\s*{([^{}]*(?:{[^{}]*}[^{}]*)*)}\\s*\\)', 'gs')
const str = `const foo = computed(() => {
// })
let total = 0
for (let i = 0; i < items.value.length; i++) {
total += items.value[i].price
}
for (let i = 0; i < items.value.length; i++) {
total += items.value[i].price
}
for (let i = 0; i < items.value.length; i++) {
total += items.value[i].price
}
return total
})`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}