using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"const\s+([a-zA-Z0-9_$]+)\s*=\s*computed\(\s*\(\)\s*=>\s*{([^{}]*(?:{[^{}]*}[^{}]*)*)}\s*\)";
string input = @"const foo = computed(() => {
// })
let total = 0
for (let i = 0; i < items.value.length; i++) {
total += items.value[i].price
}
for (let i = 0; i < items.value.length; i++) {
total += items.value[i].price
}
for (let i = 0; i < items.value.length; i++) {
total += items.value[i].price
}
return total
})";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}