$re = '/const\s+([a-zA-Z0-9_$]+)\s*=\s*computed\(\s*\(\)\s*=>\s*{([^{}]*(?:{[^{}]*}[^{}]*)*)}\s*\)/s';
$str = 'const foo = computed(() => {
// })
let total = 0
for (let i = 0; i < items.value.length; i++) {
total += items.value[i].price
}
for (let i = 0; i < items.value.length; i++) {
total += items.value[i].price
}
for (let i = 0; i < items.value.length; i++) {
total += items.value[i].price
}
return total
})';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);