use strict;
my $str = '[[
\'id\' => \'palette-3\',
\'color1\' => [ \'color\' => \'#3eaf7c\' ],
\'color2\' => [ \'color\' => \'rgb(207, 216, 225)\' ],
\'color3\' => [ \'color\' => \'#f0f0f0\' ],
\'color4\' => [ \'color\' => \'#c8c8c8\' ],
\'color5\' => [ \'color\' => \'#f0f0f0\' ],
],
]';
my $regex = qr/([\]\)]),(\s*\n*\s*)([\]\)])/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}