re = /([\]\)]),(\s*\n*\s*)([\]\)])/m
str = '[[
\'id\' => \'palette-3\',
\'color1\' => [ \'color\' => \'#3eaf7c\' ],
\'color2\' => [ \'color\' => \'rgb(207, 216, 225)\' ],
\'color3\' => [ \'color\' => \'#f0f0f0\' ],
\'color4\' => [ \'color\' => \'#c8c8c8\' ],
\'color5\' => [ \'color\' => \'#f0f0f0\' ],
],
]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end