#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^<\s*(?<Slash>/\s*)?(?<TagName>(?:esi:)?[a-zA-Z0-9-]+)(?<AttrList>[^>]*)>?$"
Local $sString = "<input src>" & @CRLF & _
"<esi:include src>" & @CRLF & _
"<esi:include src/>" & @CRLF & _
"<esi:include src />" & @CRLF & _
"<esi:include src="http://example.com/1.html" alt="http://bak.example.com/2.html" onerror="continue"/>" & @CRLF & _
"<p>" & @CRLF & _
"</p>" & @CRLF & _
"" & @CRLF & _
"<esi:in:clude src/>" & @CRLF & _
"<esi::include src/>" & @CRLF & _
"<esi::::::::::include src>" & @CRLF & _
"<:::::::::esi:include src>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")