import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^<\\s*(?<Slash>/\\s*)?(?<TagName>(?:esi:)?[a-zA-Z0-9-]+)(?<AttrList>[^>]*)>?$";
final String string = "<input src>\n"
+ "<esi:include src>\n"
+ "<esi:include src/>\n"
+ "<esi:include src />\n"
+ "<esi:include src=\"http://example.com/1.html\" alt=\"http://bak.example.com/2.html\" onerror=\"continue\"/>\n"
+ "<p>\n"
+ "</p>\n\n"
+ "<esi:in:clude src/>\n"
+ "<esi::include src/>\n"
+ "<esi::::::::::include src>\n"
+ "<:::::::::esi:include src>\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}