$re = '%^<\s*(?<Slash>/\s*)?(?<TagName>(?:esi:)?[a-zA-Z0-9-]+)(?<AttrList>[^>]*)>?$%m';
$str = '<input src>
<esi:include src>
<esi:include src/>
<esi:include src />
<esi:include src="http://example.com/1.html" alt="http://bak.example.com/2.html" onerror="continue"/>
<p>
</p>
<esi:in:clude src/>
<esi::include src/>
<esi::::::::::include src>
<:::::::::esi:include src>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);