import re
regex = re.compile(r"^<\s*(?<Slash>/\s*)?(?<TagName>(?:esi:)?[a-zA-Z0-9-]+)(?<AttrList>[^>]*)>?$", flags=re.MULTILINE)
test_str = ("<input src>\n"
"<esi:include src>\n"
"<esi:include src/>\n"
"<esi:include src />\n"
"<esi:include src=\"http://example.com/1.html\" alt=\"http://bak.example.com/2.html\" onerror=\"continue\"/>\n"
"<p>\n"
"</p>\n\n"
"<esi:in:clude src/>\n"
"<esi::include src/>\n"
"<esi::::::::::include src>\n"
"<:::::::::esi:include src>\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")