package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*filename[^/].*\.(jpg|xcf|png|jpeg)`)
var str = `filename.png
filename123.png
abcfilename123.png
abcfilename//123.png
filename12.xcf`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}