const regex = /.*filename[^/].*\.(jpg|xcf|png|jpeg)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*filename[^\/].*\\.(jpg|xcf|png|jpeg)', 'gm')
const str = `filename.png
filename123.png
abcfilename123.png
abcfilename//123.png
filename12.xcf`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}