$re = '/.*filename[^/].*\.(jpg|xcf|png|jpeg)/m';
$str = 'filename.png
filename123.png
abcfilename123.png
abcfilename//123.png
filename12.xcf';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);