import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*filename[^/].*\\.(jpg|xcf|png|jpeg)";
final String string = "filename.png\n"
+ "filename123.png\n"
+ "abcfilename123.png\n"
+ "abcfilename//123.png\n"
+ "filename12.xcf";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}