// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m).*filename[^/].*\.(jpg|xcf|png|jpeg)").unwrap();
let string = "filename.png
filename123.png
abcfilename123.png
abcfilename//123.png
filename12.xcf";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}