using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^2(([0-5]\d{2})|([6-8](([1][9])|([2-9]\d)))|([9](([2][1-9])|[3-9]\d)))$";
string input = @"2600
2599
1999
2000
2618
2619
2899
2900
2921
2920
2999
3000";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}