const regex = /^2(([0-5]\d{2})|([6-8](([1][9])|([2-9]\d)))|([9](([2][1-9])|[3-9]\d)))$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^2(([0-5]\\d{2})|([6-8](([1][9])|([2-9]\\d)))|([9](([2][1-9])|[3-9]\\d)))$', 'gm')
const str = `2600
2599
1999
2000
2618
2619
2899
2900
2921
2920
2999
3000`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}