use strict;
my $str = '2600
2599
1999
2000
2618
2619
2899
2900
2921
2920
2999
3000';
my $regex = qr/^2(([0-5]\d{2})|([6-8](([1][9])|([2-9]\d)))|([9](([2][1-9])|[3-9]\d)))$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}