import re
regex = re.compile(r"^2(([0-5]\d{2})|([6-8](([1][9])|([2-9]\d)))|([9](([2][1-9])|[3-9]\d)))$", flags=re.MULTILINE)
test_str = ("2600\n"
"2599\n"
"1999\n"
"2000\n"
"2618\n"
"2619\n"
"2899\n"
"2900\n"
"2921\n"
"2920\n"
"2999\n"
"3000")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")