# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(^|[^\.^\d])0+(\d)/\1\2/gm;t' <<< "02+03*04"