package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^|[^\.^\d])0+(\d)`)
var str = `02+03*04`
var substitution = "\1\2"
fmt.Println(re.ReplaceAllString(str, substitution))
}