$re = '/(^|[^\.^\d])0+(\d)/m';
$str = '02+03*04';
$subst = "\1\2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;